SAP e-Way hill for India - Integration with
GSP (GST Suvidha Provider)

Via SAP Cloud Integration Service
In Neo environment
GSP Integration Set Up Guide
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1. Introduction
Using the SAP Solution for eWay Bill India, you can generate eWay bill number as per the legal
requirement in India.

The e-way bill solution requires the integration between SAP Business Application (SAP ERP or
SAP S/4HANA) and GSPs. This document describes the steps to adapt and deploy the SAP
Cloud Integration content flow to establish the communication between SAP Business
Application and GSPs.

SAP Certified
GSP

SAP Cloud Integration

Note:

SAP offers two Cloud environments, namely Neo and Cloud Foundry and this document is intended for the setting-
up of e-Way Bill India integration for Neo environment.

2. Pre-requisites (only first-time activity)

Ensure the following prerequisites are met:

*  SAP eWay bill for India solution is available in your landscape. For more information
on installation and implementation, see SAP note: 2631687

* Provisioned live SAP Cloud Integration production and/or pre-production tenants.
o0 A sample of the URL'’s you'll need are:
= Account URL: https://account.hana.ondemand.com
= Web Ul URL: https://sample-tmn.avt.eul.hana.ondemand.com/itspaces
= Runtime URL: https://sample-ifimap.avtsbhf.eul.hana.ondemand.com

Use your P-user or S-user credentials to login. If you get HTTP status 403 error,
then send a mail to service@sap.com.

o0 Userrole:



= SAP Cloud Integration service user should have the ESBMessaging.Send role.

= User should have AuthGroup.Administrator role to perform steps related to
KeyStore, client certificate mapping and User credentials.

* For production access via GSP:
I.  Login to NIC web portal (https://ewaybill.nic.in/).

Il. Go to Registration > For GSP.

The webpage displays your existing GSP if any login credentials were already
created for API access through GSP. If not, continue the steps below.

Il. Click the radio button Add/New.

IV. Choose your GSP name from dropdown list and input your user credentials in
expected format.

V. Click Add to register your login credentials for E-way Bill APl access through your
GSP. For more information, see FAQ 1.
+ For sandbox access via GSP, request the NIC user credentials from GSP directly.

« Completed registration with GST Suvidha Provider (GSP) system and have received
the following:

0 GST Suvidha Provider (GSP) integration/set up manual.
o Trusted certificates from GSP for SSL handshake.

o0 NIC public key certificate (SAP Cloud Integration expects the certificate in .CER
format)

0 NIC user credentials per GSTIN.
o0 Other required technical details from GSP.

o Two Integration Flows (.zip files) from GSP and save to any local location in your
desktop.

= GSP integration flow [Integration Flow specific to GSP]

= Router integration flow [Routes e-Way Bill request from SAP business
application to specific GSP Integration Flow]

3. Establishing the connection between SAP Cloud Integration
and GSP

3.1 Certificate set-up and connection test (only first-time activity or in case of changes in
certificate from NIC/GSP)

The following steps details the procedure to establish a connection between SAP Cloud
Integration and GSP:

a. Deploying SSL certificate:
In the SAP Cloud Integration Web Ul URL, go to Monitor > Manage Security >
Keystore > Add Certificate (fill parameters here) > click Deploy > click Ok.

Note: To perform the above operation, you need to have the role as
AuthGroup.Administrator.



d.

For more information, see FAQ 2.

Connection test (recommended):

In the SAP Cloud Integration Web Ul URL, go to Monitor > Manage Security >
Connectivity tests > enter GSP base URL without https and port > click Send. On
successful connection, system displays a successful response message.

For more information, see FAQ 3.

Deploying NIC public key certificate:

In the SAP Cloud Integration Web Ul URL, go to Monitor > Manage Security >
Keystore > Add Certificate > browse NIC public certificate (certificate should be in
.CER format) > Enter alias name as niccert > click Deploy > click Ok.

For more information, see FAQ 2.

Adding NIC user credentials as per GSTIN:
In SAP Cloud Integration Web Ul URL, go to Monitor > Manage Security > Security
Material > Add > Click User Credentials (fill parameters here) > click Deploy.

For more information, see FAQ 4.

Name GSTIN of the business place to which the user belongs /
GSTIN of the business place with suffix ' _ewb’

Description Any relevant text (optional)

User User ID created in NIC portal under GSP registration option

(production) or received from GSP (pre-production)
Password/ Repeat | Password
password

Deploying client certificate to SAP Cloud Integration (optional but highly recommended):
Download the client certificate from source system.

In the SAP Cloud Integration Web Ul URL, go to Monitor > Manage Security > Manage
Certificate-to-User Mappings > click Add > Add user name as SAP Cloud Integration
user name (this user must have ESBMessaging.Send role assigned) and certificate as
client certificate from the source system.

For more information, see FAQ 6

3.2 Deploy Integration Flow

3.2.1

3.2.2

Creating content package: (one-time activity)

In the Web Ul URL of the tenant, go to Design > Create > In Header, give a meaningful
name (technical name), short description and click Save. The content package is
created.

Updating content package

When you already have previous version of integration flow deployed in your tenant and
need to replace it with new integration flow, then follow below instructions



o choose the content package under which the previous integration flow is

deployed.
0 Click on “Edit” button (seen in left side)
o] Go to artifacts tab, checkmark the integration flow,
o] Then click on action icon = configure. Copy the values of the

fields maintained over there locally, as it can be used later if GSP confirms these
parameters are valid or get the exact latest externalized parameters values.
Close the configure pop-up screen.

o] checkmark the integration flow, then click on action icon = delete.

Note: Repeat this ‘Updating content package’ step for each of the router and GSP
integration flows.

3.2.3 Deploying Router integration flow

a. Within the same content package, in artifacts tab, click Add > Integration flow >
choose Upload > browse to the router integration flow (.zip file), give a name,
description, sender, receiver > click Ok.

Integration flow is successfully added.
b. Select the Router integration flow. System displays the integration flow screen.

c. To configure and deploy:
In Artifacts screen, against the router integration flow, click Actions >
Configure > verify the value as shown in the image below:

Sender|

Sender Sender
Adapter Type SOAP
Connection
Address /indiaewaybilledoc

d. Click Save then Deploy.

3.2.4 Deploying GSP integration flow:

In the content package, in Artifacts tab, click Add > Integration flow > choose
Upload > browse to the GSP integration flow (.zip file), give a name, description, sender,
receiver = click Ok. Now, integration flow is successfully added.

Select the GSP integration flow. System displays the integration flow screen.



2 Router [SAP

Start

ProcessDirect

General

CONNECTION DETAILS
Address: N
For more information, see FAQ 5.

Double click the processdirect > connection details > address > make note of this
value (sample: /gsp)

ProcessDirect

General  [Connection

CONNECTION DETAILS
Address:

Note: You should enter the service provider name as same as the address value (without
slash) in the business application > sm30 > in view EDOINEWBGSPV.

Display View "View for eDocument India eWay Bill GSP Details": Overvie

SelectAll  SelectBlock  DeselectAll  More v

View for eDocument India eWay Bill GSP Details

CoCd BP Service Provider Name

e
After that to configure and deploy:

In Artifacts screen, against the GSP integration flow, click Actions > Configure > Define
the externalized parameters as provided by GSP to SAP customer. In case of updating the new

integration flow, use the parameters copied as suggested in the step 3.2.2. After updating the
parameters, click Save then Deploy.



Intagration Flow

General Runtima Configuration Emor Configuration Resources Extermalized Parameters Problams
Name Value
=gep>_auth_url

<gsp>_clianl-sacrat

=gsp>_clienlid

=gsp>_ewaybil_url

<gsp>pkalias -
nic_ loken_axpiny

nicpkalias

Note: NIC public key alias value is the same as the alias of the NIC public key certificate
you deployed (niccert).

Important:

After the successful deployment, verify that the integration flows are in the Started
state by clicking Monitor > Manage integration content.

To obtain the EndPoint URL :
I. Click Monitor > Manage integration content

Il. Choose the Router Integration flow.
Ill. The EndPoint URL can be found on the right side of the page.

ROUter Restart Undeploy

Deployed On: Jsiimiiimiitetii ID: com.sap.slh.dcs.ewb.router

Deployed By: et Version: 1.0.0
Endpoints Status Details Artifact Details Log Configuration
https:/ ‘it =
ifimap.hcisbp.eu1.hana.ondemand.com/cxf/indiaewaybilledoc 2
WSDL T O
WSDL for ABAP consumer + 4
WSDL without policies L o4

IV. This URL has to be configured in the SOA Manager.



New Manual Configuration of Logical Port for Consumer Proxy ‘'CO_EDO_IN_EWB_TRAN?

* 1 2 n 4 5 t

Logical Por Name Consumer Secury HTTPSettings SOAF Protocol isenttabie Business Context Uptranor

Back | Nex! || Finish || Gancel
URL Access Path

* Complete URL URL components

- URL o
Logon Language: L.mgu:g-f.' User Contaxt v
Proxy

Narme of Proxy Host

Port Number of P‘f.," Host
Uses Name for Proxy Access

Password of Proxy User

Transport Binding

Make Local Ca No Call in Local System o
* Transport Binding Type: SOAP 11 ~
Maxmum Wal for WS Consumer ]

Any issues with:

0 SAP Cloud Integration tenant: Report under SAP component: LOD-HCI-PI-OPS
o EWB: Report under SAP component: XX-CSC-IN-EWB

0 GSP system access: Report through GSP defined support mechanism



FAQs:

1. Reqistering your Login Credentials for E-way Bill API

To register your login credentials for E-way Bill API, access through GSP in NIC portal.

a. Customer must login to NIC web portal (https://ewaybill.nic.in/).

« oe - caavbliu gen i - 00 i+t mODe =

E - WAY BILL SYSTEM LOGIN

b. Go to Registration > For GSP > The webpage shall now display your existing GSP (if any
login credentials were already created for API access through GSP). If not, click
Add/New. Choose your GSP name from dropdown list and input your user credentials in

the expected format. Click Add to register your login credentials for E-way Bill API
access through your GSP.

« ce e vttt g

GOODS AND SERVICES TAX
E - WAY BILL SYSTEM




£ - WAY BILL SYSTEM

Register your GST Suvidha Provider

View Froezs Change Password

GSP Name ~Select User— .
User Name |

AP\

J
T

Passwor T
Re-Enter User Narme 8

Re-Erter Pasuword

| s I

This is the NIC portal
-__

> 1l isa
~ prepopulated suffix )

2. Adding New Certificates to the SAP Cloud Integration
You can add the security artifacts like keystore entries by following the process detailed here.

You should have Tenant Admin authorizations (AuthGroup.Administrator role) for the tenant to
perform this operation.

a. Navigate to Monitor > Manage Security > Keystore.

%t Seltings

Manage Security

Security Material Keystore Certificate-to-User System Change Log Connectivity Tests
Mappings
Artifacts Entries Artifacts

b. Click Add > Certificate > Add Certificate.



o SAP Cloud Platform Integrai < <4

€ | @ B  https//b2bent00-tmn.hd.int.sap.hana.ont € Q Search wa ¥+ & =

SAP Cloud Platform Integration

) Overview / Manage Keystore

Entries (20) : : Q || Aga ||| Downioad | | C | | %

~

Tx Alias Action

Cument  Backup  NewSAPkeys  SAP Key History

Cartficate

L Add | Downboad | (| %

Key Store

HMias Typa Ownel Valld Untl 51 Modfied At Achons

c. Enter an alias to identify the certificate. Browse the certificate from local desktop.

Add Certificate

*Alias: I [Enter an alias for the certificate I

Tl Choose a certificate for upload. .. Browse.. .

d. Click Deploy.

3. Connectivity Test
To check the connectivity with GSP, follow the steps:

a. Go to Monitor

b. Choose Manage Security > Connectivity tests



Manage Security
Security Material Keystore Certificate-to-User Connectivity Tests
Mappings
Artifacts Entries Artifacts

c. Enter the host URL without any Protocols and enter the port number. Click on Send.

Request

*Host: ‘ ww example org

*Port: | 443
Authenticate with Client Certificate

v| Validate Server Certificate

d. On successful connection, you can see a response as shown below:

Response

Successfully reached host at s ———— 443

Client Certificate Used No

Certificates

AT o
issuerDN=CN=Amazon, OU=Server CA 1B, O=Amazon, C=US
subjectAlternativeNames=DNSN.
validUntil=Mar 07, 2019, 17:30:00
serialNumber=0xAA2BB42565C2634EAG67F40F984CB420

2 dn=CN=Amazon, OU=Server CA 1B, O=Amazon, C=US
issuerDN=CN=Amazon Root CA 1, O=Amazon, C=US
validUntil=0ct 19, 2025, 05:30:00
serialNumber=0x67F94578587E8AC77DEB253325BBC998B560D

3 dn=CN=Amazon Root CA 1, O=Amazon, C=US

4. Adding User Credentials to SAP Cloud Integration

To add User Credentials (per GSTIN credentials provided by GSP/NIC) to SAP Cloud
Integration:



You register the user as per the business place specified in NIC. Use the following steps to add
these NIC users in SAP Cloud Integration:

a. Go to Security material. Navigate to Monitor > Manage Security > Security Material.

Manage Security

Security Material Keystore Certificate-to-User Connectivity Tests
Mappings
Artifacts Entries Artifacts

b. Add a new user credential.

Overview | Manage Security Material

sterial (22 Q Gl |

c. Click User Credentials.

content adv
Known Hosts (SSH)

OAuth2 Credentials

PGP Public Keyring

PGP Secret Keyring

Secure Parameter

User Credentials

d. Add and Deploy the user credentials.

Add User Credentials

*Name: I |

Description:
*User:

Password:
Repeat Password:

SuccessFactors

Deploy [ Cancel




Note: in the Name field, enter the GSTIN of the business place to which the user belongs.

5. Creating content package and Deploying GSP integration flow
To create a content package, follow the steps:

a. Go to Design.

Discover

Z/ Design

@ Monitor

*%3 Settings

b. Choose Create.

/ Design
Packages (0) Filter QT
Name Mode Versi Created By Created Date Description s

No data

c. Enter appropriate Name and Description and click Save.

To deploy GSP integration flow, follow the steps:



a. Choose Artifacts.

Header Qverview Documents Tags

Name

b. Click Add and choose Integration Flow.

Type Version
No data Integration Flow
OData Service
Value Mapping
c. Select Upload.
d. Browse for the appropriate Integration flow (.zip file)
e. Enter the Name and Description and click Ok.
Add integration flow artifact
*Integration Flow: | ~S11g/e File>
*Name: | |meyewem—
<Description=
Description:
Sender: | <sender> Receiver: | <Receiver>

6. Deploying Client Certificate to SAP Cloud Integration

To deploy client certificate to SAP Cloud Integration, follow the steps:



For inbound HTTP connections to SAP Cloud Integration, you define Authorization options for
the communication user associated with the sender system to define how it accesses the Cloud
Integration components. We recommend that you use Client-Certificate with certificate-to-user
mapping. Under this option, the authentication of a sender is performed based on a client
certificate. With a certificate-to-user mapping, the certificate is mapped to a user, whose
authorizations are checked on the tenant.

a. Navigate to Monitor > Manage Security > Certificate-to-User Mappings.

Manage Security

Security Material

22

Artifacts

Keystore Certificate-to-User
Mappings
Entries Avrtifacts

Connectivity Tests

b. Click Add.

Certificate-to-User Mappings (1)

Q Edit Delete C %

c. Enter the service user and deploy the client certificate obtained from SAP ERP.

Note: the service user should have the ESBMessaging.Send role assigned to it.

For more information on how to obtain client certificate from SAP ERP, refer the section
‘Configure Service Providers and Consumer Proxies’ in
‘eWay_Bill_Installation_and_Configurations’ document attached to SAP note: 2631687

Add Certificate-to-User Mapping

*User Name: -

*Certificate

Browse...

OK Cancel




APPENDIX
About SAP Cloud Integration tenant

With SAP eWay bill solution, you get two Cloud Integration tenants. For each tenant, you get a
welcome email outing the details about the tenant.

We recommend that you use one tenant for development/testing, and another for production.
-

w’ SAP Cloud Integration

]
Dear Customer,

Wigtcome o SAF Cloud, the most comprehensive cloud computing portiohio on the market

Reason (o contact you:
The sel-up of your SAF Cloud Platfonm Integralion enant IS complete and we ane Rappy 1o rélease i o
YOl ACCESS 10 The Sy stem s configured via HTTPS, You can Bccess rom anywhens in the workd

Custemer Information:
Customar Mame: ABC
Cusiomer 1D 1234567620

Custormer name and D

Key Mazsage:
Enclosed you will find the logon information. Pleass visil the link below with your S 1D user to start
WS e Serice

::,l:_..m =01 ?3-“5'5? S-User ID mentioned in the order form Provided dunng contract skgneg
URL: mips daccount nana ondemand com ITEINEE a il
Order Details:

SAP Cloud Platform Integration, (SAF CF Integration, enternprise edition. 8004741 ) IR =0 DT

Account: Productive

Cloud Integration Producine - DO [ E e e e s L

Wabh LI LIRL (Access via wieh Drowsar)
IR AL el e ud_hane orakemand comdispeces  EETETREE S TErs § et R e T

Managemen! URL (Access via Eclipse plugin)
]trllps_-’.-'lW-mm e R Tt L Mela e el s Rl LIFEL (o e used n Echipse Toolng

Runtime LURL {(Webserdoe ur (o be configured in backend sysiems

s R - T DS OO, e, DN TSN, CONT)

Certiticate Information Securty Cerlificate Informalion

Yol may directly EID‘M'I-IUIECI the SAP Cloud Plattorm integration clhent cerificate and the rool certificatles
from The Bk

nips fcerimanagnt webseouniy. symaniec. comimospienrollfsearchoot Delails TissuerSoenal=d 32 faZDaatd
NODOEoOCOOOUSIUr_ Nashi=EE1 39 Se00000onono0oood AGASHDOTICSOS (please use the X509 certificate option)

Help: Official Documeanlation
For mone information. check out the SAP Clowd FPlatform Integration documeniation at
hilps droloudintegration hana ondemand comEiweip

Please do nol reply o this email. This IS an unmonitonsd mallbosx, If you have any furher questicns,
please reporl an inchdent on the companent LOD-HCE via Dlp ASuppon sap com

Best Regands,
sAP

3 - b i -

Adding Members to the SAP Cloud Integration Account

To add members to the SAP Cloud Integration account, follow the steps:

a. Logon to the Account URL with the SAP ID user provided in the mail.
b. Add members and assign roles to this account by navigating to Members > Add Members.



Repositories

Resource Consumption

Tenants

Members

c. Assign the following roles.
« Administrator: Assign the role of Administrator to the user who is supposed to have
the full permissions of an administrator.

« Application User Admin: Assign the role of Application User Admin to the user who
is supposed to have restricted administrator privileges.

Add Members

Enter up to 100 SAP user IDs. To separate them, you can use commas, spaces, semicolons, or line breaks.

User IDs: Assign roles:

| v | Administrator (predefined role)
Developer (predefined role)

Support User (predefined roie)
Application User Admin (predefined role)

Cloud Connector Admin (predefined role)

CloudConnector

Comment (optional, visible to all members):

Providing authorizations to SAP Cloud Integration Users

To provide authorizations to the SAP Cloud Integration Users:

d. Logon to the Account URL with the SAP ID user provided in the mail.
e. Inthe Navigation pane, choose Security > Authorizations

f. Create a Group and assign Roles and users for this Group.



Autheorization Management

users | Groups | Token

Lp AS3EN Web Roles and Users to Inaividual Sroups

&J | fortenant ™ -
Sroups (Al 2) [ New Sreup

Name Actions
u

Participants w
Foles  Assign  Unassign Al Indwidual Lsers Assign  Unassign AN
Subaccount Application o RO Actions user
awraev <o fimap EsBMessaging.senc Unassign
avrdev ** mmomn AUthGroup Administrator Unassign
awraev wn AUNGIOUD Integrancno Unassign
avrday =+ ==tmn AuthGroup BusinessEx Uinassign

Mappings defined by trusted identily providers

The authorization group AuthGroup.Administrator is designed for the administrator at customer
side who administers a (customer-specific) tenant management node.

For more details refer here.

Creating a Service User in SAP Cloud Integration

To create a Service User in SAP Cloud Integration, follow the steps:

g. Register a new user at https://account.hana.ondemand.com/#/home/welcome.
h. Assign the ESBMessaging.Send role to the user.

Assign roles to user — °- "7 "7 T 77 =

Supaccount =" ~ | subaccount
Application ~ | iflmap
ifimap,

Hole: I ESBRMessaging send Iv

MNote: Chranges will affect iew SessSions ol

Save Cancel




Useful links:

*  SAP Cloud Integration:
https://help.sap.com/viewer/product/CLOUD INTEGRATION/Cloud/en-US

*  SAP Cloud Integration — overview of authorization groups:

https://help.sap.com/viewer/368c481cd6954bdfa5d0435479fd4eaf/Cloud/en-
US/2937e5cabef448cfb21451a2461cc2a6.html

* SAP Cloud Integration — user credentials:
https://help.sap.com/viewer/368c481cd6954bdfa5d0435479fd4eaf/Cloud/en-
US/6912d63bbbc64aee8bbd4ff10314c60c.html

* SAP Cloud Integration — Importing a keystore:
https://help.sap.com/viewer/368c481cd6954bdfa5d0435479fd4eaf/Cloud/en-
US/0db193a325a94675928e717¢9310734a.html

* SAP Cloud Integration — Importing a certificate:

https://help.sap.com/viewer/368c481cd6954bdfa5d0435479fd4eaf/Cloud/en-
US/03cf78a217574e7abd75bfbba990c085.html
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